Back to overview
Degraded

Issue Affecting E-Commerce Orders via Vantiv Payment Gateway

Mar 25 at 07:34am UTC
Affected services
Platform
Open API

Resolved
Mar 26 at 05:48pm UTC

A fix has been deployed, and we are actively monitoring the platform to ensure normal operations have resumed.

We appreciate your patience and apologize for any inconvenience this may have caused. If you experience any further issues, please contact our support team at support@pelcro.com.

Created
Mar 25 at 07:34am UTC

We are currently experiencing an issue on our platform affecting E-Commerce orders processed through the Vantiv payment gateway, which is preventing users from completing the transactions. Our team has identified the root cause and is actively working on deploying a fix.

We apologize for any inconvenience this may cause and will provide updates as soon as possible.

If you have any questions or concerns, please reach out to us at support@pelcro.com.