Issue with Marking Invoices as Paid
Resolved
Mar 18 at 02:17pm UTC
Postmortem
Incident:
On March 17th, 2025, during the release of version 1.92.0, a bug was introduced in a task aimed at enhancing the security of certain platform flows.
Impact:
This bug directly impacted users who rely on the platform's invoicing feature, preventing them from marking invoices as paid. No data was lost, and other platform functionalities remained unaffected.
Moving forward:
We are taking steps to improve our internal processes and testing protocols to prevent similar incidents in the future. Our focus remains on delivering a seamless and reliable experience for our users.
Affected services
Platform
Updated
Mar 17 at 06:20pm UTC
A fix has been released, and we are monitoring it closely.
We appreciate your patience and apologize for any inconvenience caused. If you experience any further issues, please contact our support team at support@pelcro.com.
Affected services
Platform
Updated
Mar 17 at 04:20pm UTC
We are still working on resolving the issue preventing users from marking invoices as paid. While our team has identified the root cause, the fix is taking longer than anticipated. We are committed to resolving this as soon as possible and will keep you updated on our progress.
We apologize for the inconvenience and appreciate your patience. If you have any questions, please reach out to us at support@pelcro.com.
Affected services
Platform
Created
Mar 17 at 03:15pm UTC
We are experiencing an issue on the platform preventing users from marking invoices as paid. Our team has identified the root cause and is actively working on deploying a fix within the next hour.
We apologize for any inconvenience this may cause and will provide updates as soon as possible.
If you have any questions or concerns, please contact us at support@pelcro.com.
Affected services
Platform