Account List Page Access Issue
Resolved
Mar 15 at 06:50pm UTC
Postmortem
Incident
On March 15th, 2025, some users encountered a 500 error when attempting to log in to the platform. This issue specifically affected collaborators who were associated with multiple accounts and whose session had previously expired.
Impact
The incident resulted in affected users being unable to access their dashboards, disrupting their workflow and limiting their ability to manage their accounts. Only a subset of collaborators experienced this issue. Other collaborators were able to access the platform without interruption.
Moving Forward
We have identified the root cause of the issue and implemented a fix to prevent similar errors in the future.
Affected services
Platform
Updated
Mar 15 at 02:29pm UTC
A fix has been released, and we are monitoring it closely.
We appreciate your patience and apologize for any inconvenience caused. If you experience any further issues, please contact our support team at support@pelcro.com
Affected services
Platform
Created
Mar 15 at 01:42pm UTC
We are currently experiencing an issue with the Account List page, which is preventing users from accessing their accounts. Our team is actively investigating the root cause and working on a resolution.
We apologize for the inconvenience and will provide updates as soon as possible.
If you have any questions or concerns, please contact us at support@pelcro.com.
Affected services
Platform